using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)[.,;:?!-](?!\d)";
string substitution = @" ";
string input = @"This is a 1example of the text. But, it only is 2.5 percent of all data"" shit-ass";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}