import re
regex = re.compile(r"(?<!\d)[.,;:?!-](?!\d)")
test_str = "This is a 1example of the text. But, it only is 2.5 percent of all data\" shit-ass"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)