const regex = new RegExp('(?<!P\\d\\d\\+)P\\d\\d\\+P\\d\\d(?!\\+P\\d\\d)', 'gm')
const str = ` P50+P60, P50+P40+P30`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}