$re = '/(?<!P\d\d\+)P\d\d\+P\d\d(?!\+P\d\d)/m';
$str = ' P50+P60, P50+P40+P30';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);