package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`09[0-9]{9}`)
var str = `09321312322`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}