$re = '/09[0-9]{9}/';
$str = '09321312322';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);