import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:\\d[- _]*){6,})|(?<num_1>\\d[- _]*)(?<num_2>\\d[- _]*)(?<num_3>\\d[- _]*)(?<num_4>\\d)(?<num_5>[- _]*\\d)?";
final String string = "\"1-2-3-4-5-6\" => no\n"
+ "\"1-2-3-4-5\" => yes match 1\n"
+ "\"1-2-3-4\" => yes match 2\n"
+ "\"1-2-3\" => no\n"
+ "\"123456\" => no\n"
+ "\"12345\" => yes match 3\n"
+ "\"1234\" => yes match 4\n"
+ "\"123\" => no\n"
+ "foo 123 56 78 bar\n"
+ "\"0000\" will become \"****\"\n"
+ "\"any text 000 00 more texts\" will become \"any text ***** more texts\"..notice that the space is removed\n"
+ "\"any text 000 00 more texts 00\" will become \"any text ***** more texts 00\"\n\n"
+ "\"any text 000 00 more texts 00 00\" will become \"any text ***** more texts ****\"\n\n"
+ "\"any text 00-00 more texts 00_00\" will become \"any text **** more texts ****\"\n"
+ "a 0 12345 fdf";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}