# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?:\d[- _]*){6,})|(?<num_1>\d[- _]*)(?<num_2>\d[- _]*)(?<num_3>\d[- _]*)(?<num_4>\d)(?<num_5>[- _]*\d)?"
test_str = ("\"1-2-3-4-5-6\" => no\n"
"\"1-2-3-4-5\" => yes match 1\n"
"\"1-2-3-4\" => yes match 2\n"
"\"1-2-3\" => no\n"
"\"123456\" => no\n"
"\"12345\" => yes match 3\n"
"\"1234\" => yes match 4\n"
"\"123\" => no\n"
"foo 123 56 78 bar\n"
"\"0000\" will become \"****\"\n"
"\"any text 000 00 more texts\" will become \"any text ***** more texts\"..notice that the space is removed\n"
"\"any text 000 00 more texts 00\" will become \"any text ***** more texts 00\"\n\n"
"\"any text 000 00 more texts 00 00\" will become \"any text ***** more texts ****\"\n\n"
"\"any text 00-00 more texts 00_00\" will become \"any text **** more texts ****\"\n"
"a 0 12345 fdf")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.