#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)[a-z][a-z' ]*(?= |,|$)"
Local $sString = "july 25, 2010" & @CRLF & _
"red, white, blue" & @CRLF & _
"redish blue, orange" & @CRLF & _
"july 2015" & @CRLF & _
"that's awesome" & @CRLF & _
"test" & @CRLF & _
"hi" & @CRLF & _
"I"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")