$re = '/[a-z][a-z\' ]*(?= |,|$)/im';
$str = 'july 25, 2010
red, white, blue
redish blue, orange
july 2015
that\'s awesome
test
hi
I';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);