package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\s\w\dа-яА-ЯёЁ]`)
var str = `13!213$4124%ф^ы вф"ы'aa@gпёЁ12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}