// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^\s\w\dа-яА-ЯёЁ]").unwrap();
let string = "13!213$4124%ф^ы вф\"ы'aa@gпёЁ12";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}