#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)user_b: (.*?)(?=^[0-9]{2}/[0-9]{2}/[0-9]{2})"
Local $sString = "27/07/18, 12:02 PM - user_a: https://www.youtube.com/" & @CRLF & _
" Watch this" & @CRLF & _
"27/07/18, 12:15 PM - user_b: <Media omitted>" & @CRLF & _
"27/07/18, 12:52 PM - user_b: Read this fully" & @CRLF & _
"some text" & @CRLF & _
"some text" & @CRLF & _
"." & @CRLF & _
"some text" & @CRLF & _
"27/07/18, 12:56 PM - user_c: text .."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")