import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "user_b: (.*?)(?=^[0-9]{2}/[0-9]{2}/[0-9]{2})";
final String string = "27/07/18, 12:02 PM - user_a: https://www.youtube.com/\n"
+ " Watch this\n"
+ "27/07/18, 12:15 PM - user_b: <Media omitted>\n"
+ "27/07/18, 12:52 PM - user_b: Read this fully\n"
+ "some text\n"
+ "some text\n"
+ ".\n"
+ "some text\n"
+ "27/07/18, 12:56 PM - user_c: text ..";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}