package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[^7]*7){4}([^7]*)`)
var str = `edbe801bf92fe7b770f72df2d722df0a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}