package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\W+|\b\w{1,2}\b`)
var str = `This is a short text about StackOverflow.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}