$re = '/\W+|\b\w{1,2}\b/';
$str = 'This is a short text about StackOverflow.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);