package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)forum\/index\.php.+?\bmsg=?(\d+)`)
var str = `Test strings that should give me the message ID:
/forum/index.php/topic,101126.msg3826887.html#msg3826887
/forum/index.php?topic=101126.msg3826887#msg3826887
/forum/index.php?msg=3826887
Test strings that should fail:
/forum/index.php?msgrad3826887
/forum/index.php?msg,3826887
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}