$re = '/forum\/index\.php.+?\bmsg=?(\d+)/m';
$str = 'Test strings that should give me the message ID:
/forum/index.php/topic,101126.msg3826887.html#msg3826887
/forum/index.php?topic=101126.msg3826887#msg3826887
/forum/index.php?msg=3826887
Test strings that should fail:
/forum/index.php?msgrad3826887
/forum/index.php?msg,3826887
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);