#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^([^.\n]*)(?:\.([^.\n]*))?(?:\.([^.\n]*))?(?:\.([^.\n]*))?(?:\.([^.\n]*))?(?:\.([^.\n]*))?(?=#)"
Local $sString = "1This.2is.3a tester text.4foo.5jll.6hhh.7text#" & @CRLF & _
"1This.2is.3a tester text.4foo.5jll.6hhh#" & @CRLF & _
"1This.2is.3a tester text.4foo.5jll#" & @CRLF & _
"1This.2is.3a tester text.4foo#" & @CRLF & _
"1This.2is.3a tester text#" & @CRLF & _
"1This.2is#" & @CRLF & _
"1This#"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")