$re = '/(?m)^([^.\n]*)(?:\.([^.\n]*))?(?:\.([^.\n]*))?(?:\.([^.\n]*))?(?:\.([^.\n]*))?(?:\.([^.\n]*))?(?=#)/m';
$str = '1This.2is.3a tester text.4foo.5jll.6hhh.7text#
1This.2is.3a tester text.4foo.5jll.6hhh#
1This.2is.3a tester text.4foo.5jll#
1This.2is.3a tester text.4foo#
1This.2is.3a tester text#
1This.2is#
1This#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);