$re = '/(you)(?!tube\b).*(\.co(?:m|\.uk)).*(/watch)/m';
$str = 'https://www.youtube.com/watch...
https://www.youfake.com/watch...
https://www.youlube.co.uk/watch...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);