re = /(you)(?!tube\b).*(\.co(?:m|\.uk)).*(\/watch)/m
str = 'https://www.youtube.com/watch...
https://www.youfake.com/watch...
https://www.youlube.co.uk/watch...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end