#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)<scritp>.*?site.*?<\/script>"
Local $sString = "<scritp>" & @CRLF & _
"o.com" & @CRLF & _
"bla bla bla" & @CRLF & _
"</script><p>this is line></p>" & @CRLF & _
"" & @CRLF & _
"<script>" & @CRLF & _
"google.com/jquery.js !" & @CRLF & _
"</script>" & @CRLF & _
"" & @CRLF & _
"<scritp>" & @CRLF & _
"site.com" & @CRLF & _
"bla bla bla" & @CRLF & _
"</script><p>aa</p>" & @CRLF & _
"" & @CRLF & _
"CONTENT" & @CRLF & _
"STYLE" & @CRLF & _
"SIDEBAR" & @CRLF & _
"..." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<scritp>" & @CRLF & _
"site.com" & @CRLF & _
"aaa bla bla bla" & @CRLF & _
"</script><p>a</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")