$re = '/<scritp>.*?site.*?<\/script>/si';
$str = '<scritp>
o.com
bla bla bla
</script><p>this is line></p>
<script>
google.com/jquery.js !
</script>
<scritp>
site.com
bla bla bla
</script><p>aa</p>
CONTENT
STYLE
SIDEBAR
...
<scritp>
site.com
aaa bla bla bla
</script><p>a</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);