using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!color: )(?<!color:)(?<!pid=[0-9][0-9][0-9][0-9][0-9])\#(\w+)";
string input = @"<span style=""font-weight: bold;"">test1<span style=""color: #FFA500;"">test2</span>test3</span>#hello#how#are#you
<span style=""font-weight: bold;"">test1<span style=""color: #FFA500;"">test2</span>test3</span>#lalala #hello
<div class=""post_body"" id=""pid_58705"">
<blockquote><cite><span> (Hoy 02:42)</span>Moroha escribió: <a class=""quick_jump"" href=""http://test.com/Thread-hello?pid=58672#pid58672"" rel=""nofollow""> </a></cite>testing</blockquote></div>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}