re = /(?<!color: )(?<!color:)(?<!pid=[0-9][0-9][0-9][0-9][0-9])\#(\w+)/i
str = '<span style="font-weight: bold;">test1<span style="color: #FFA500;">test2</span>test3</span>#hello#how#are#you
<span style="font-weight: bold;">test1<span style="color: #FFA500;">test2</span>test3</span>#lalala #hello
<div class="post_body" id="pid_58705">
<blockquote><cite><span> (Hoy 02:42)</span>Moroha escribió: <a class="quick_jump" href="http://test.com/Thread-hello?pid=58672#pid58672" rel="nofollow"> </a></cite>testing</blockquote></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end