const regex = /(?i)((\d+)(x)(\d+)(\s*)(,*)(\s*))*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)((\\d+)(x)(\\d+)(\\s*)(,*)(\\s*))*', '')
const str = `320x50, 300x250,1000X50 500x30`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}