re = /(?i)((\d+)(x)(\d+)(\s*)(,*)(\s*))*/
str = '320x50, 300x250,1000X50 500x30'
# Print the match result
str.match(re) do |match|
puts match.to_s
end