import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\\"attributes\\\":) (\\{(?:(?:[^\\{]*?\\{(?:[^\\{]|\\n)*?\\}[^\\{]*?)+|(?:[^\\{]|\\n)*?)\\})";
final String string = "{\"items_game\": {\n"
+ " \"prefabs\": {\n"
+ " ...\n"
+ " \"coupon_crate_prefab\": {\n"
+ " \"prefab\": \"weapon_case_base\",\n"
+ " \"item_type\": \"coupon_crate\",\n"
+ " \"attributes\": {\n"
+ " \"cannot trade\": \"1\"\n"
+ " },\n"
+ " \"capabilities\": {\n"
+ " \"can_delete\": \"0\"\n"
+ " },\n"
+ " \"attributes\": {\n"
+ " \"expiration date\": {\n"
+ " \"attribute_class\": \"expiration_date\",\n"
+ " \"force_gc_to_generate\": \"1\",\n"
+ " \"use_custom_logic\": \"expiration_period_days_from_now\",\n"
+ " \"value\": \"2\"\n"
+ " }\n"
+ " }\n"
+ " }\n"
+ " ...\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}