# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\"attributes\":) (\{(?:(?:[^{]*?\{(?:[^{]|\n)*?\}[^{]*?)+|(?:[^{]|\n)*?)})"
test_str = ("{\"items_game\": {\n"
" \"prefabs\": {\n"
" ...\n"
" \"coupon_crate_prefab\": {\n"
" \"prefab\": \"weapon_case_base\",\n"
" \"item_type\": \"coupon_crate\",\n"
" \"attributes\": {\n"
" \"cannot trade\": \"1\"\n"
" },\n"
" \"capabilities\": {\n"
" \"can_delete\": \"0\"\n"
" },\n"
" \"attributes\": {\n"
" \"expiration date\": {\n"
" \"attribute_class\": \"expiration_date\",\n"
" \"force_gc_to_generate\": \"1\",\n"
" \"use_custom_logic\": \"expiration_period_days_from_now\",\n"
" \"value\": \"2\"\n"
" }\n"
" }\n"
" }\n"
" ...\n"
" }\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.