package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^((?:apple|mango|banana)(?:\s+(?:apple|mango|banana))*)\s+is\s+(\d+)kg\s*$`)
var str = `banana is 45kg
apple banana is 56kg `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}