re = /^((?:apple|mango|banana)(?:\s+(?:apple|mango|banana))*)\s+is\s+(\d+)kg\s*$/mi
str = 'banana is 45kg
apple banana is 56kg '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end