import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<ip>.*?) - - \\[(?P<date>.*?)(?= ) (?P<timezone>.*?)\\] \\\"(?P<request_method>.*?) (?P<path>.*\\.php.*?)(?P<request_version> HTTP/.*)?\\\" (?P<status>(301|404)?) (?P<length>.*?) \\\"(?P<referrer>.*?)\\\" \\\"(?P<user_agent>.*?)\\\"$";
final String string = "66.249.69.152 - - [21/Apr/2019:00:17:11 +0300] \"GET /assets/files/xt9jrjx/xvzbuoq.php?uonaemsxx=top-news-widgets HTTP/1.1\" 404 3713 \"-\" \"Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}