# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"YAHOO.Finance.SymbolSuggest.ssCallback\((.*?)\)"
test_str = "YAHOO.Finance.SymbolSuggest.ssCallback({\"ResultSet\":{\"Query\":\"google\",\"Result\":[{\"symbol\":\"GOOG\",\"name\":\"Google Inc.\",\"exch\":\"NMS\",\"type\":\"S\",\"exchDisp\":\"NASDAQ\",\"typeDisp\":\"Equity\"},{\"symbol\":\"GOOGL\",\"name\":\"Google Inc.\",\"exch\":\"NMS\",\"type\":\"S\",\"exchDisp\":\"NASDAQ\",\"typeDisp\":\"Equity\"},{\"symbol\":\"GGQ1.DE\",\"name\":\"Google Inc.\",\"exch\":\"GER\",\"type\":\"S\",\"exchDisp\":\"XETRA\",\"typeDisp\":\"Equity\"},{\"symbol\":\"GOOG.MX\",\"name\":\"Google Inc.\",\"exch\":\"MEX\",\"type\":\"S\",\"exchDisp\":\"Mexico\",\"typeDisp\":\"Equity\"},{\"symbol\":\"GOOG34.SA\",\"name\":\"Google Inc.\",\"exch\":\"SAO\",\"type\":\"S\",\"exchDisp\":\"Sao Paolo\",\"typeDisp\":\"Equity\"},{\"symbol\":\"GOOGL.BA\",\"name\":\"Google Inc.\",\"exch\":\"BUE\",\"type\":\"S\",\"exchDisp\":\"Buenos Aires\",\"typeDisp\":\"Equity\"},{\"symbol\":\"1916494.EX\",\"name\":\"GOOGLE-A\",\"exch\":\"EUX\",\"type\":\"S\",\"exchDisp\":\"EUREX Futures and Options Exchange \",\"typeDisp\":\"Equity\"},{\"symbol\":\"GGQ7.DE\",\"name\":\"Google Inc.\",\"exch\":\"GER\",\"type\":\"S\",\"exchDisp\":\"XETRA\",\"typeDisp\":\"Equity\"},{\"symbol\":\"GOOAV\",\"name\":\"Google Inc.\",\"exch\":\"NMS\",\"type\":\"S\",\"exchDisp\":\"NASDAQ\",\"typeDisp\":\"Equity\"},{\"symbol\":\"GGQ7.MU\",\"name\":\"GOOGLE-C\",\"exch\":\"MUN\",\"type\":\"S\",\"exchDisp\":\"Munich\",\"typeDisp\":\"Equity\"}]}})"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.