// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"YAHOO.Finance.SymbolSuggest.ssCallback\((.*?)\)").unwrap();
let string = "YAHOO.Finance.SymbolSuggest.ssCallback({\"ResultSet\":{\"Query\":\"google\",\"Result\":[{\"symbol\":\"GOOG\",\"name\":\"Google Inc.\",\"exch\":\"NMS\",\"type\":\"S\",\"exchDisp\":\"NASDAQ\",\"typeDisp\":\"Equity\"},{\"symbol\":\"GOOGL\",\"name\":\"Google Inc.\",\"exch\":\"NMS\",\"type\":\"S\",\"exchDisp\":\"NASDAQ\",\"typeDisp\":\"Equity\"},{\"symbol\":\"GGQ1.DE\",\"name\":\"Google Inc.\",\"exch\":\"GER\",\"type\":\"S\",\"exchDisp\":\"XETRA\",\"typeDisp\":\"Equity\"},{\"symbol\":\"GOOG.MX\",\"name\":\"Google Inc.\",\"exch\":\"MEX\",\"type\":\"S\",\"exchDisp\":\"Mexico\",\"typeDisp\":\"Equity\"},{\"symbol\":\"GOOG34.SA\",\"name\":\"Google Inc.\",\"exch\":\"SAO\",\"type\":\"S\",\"exchDisp\":\"Sao Paolo\",\"typeDisp\":\"Equity\"},{\"symbol\":\"GOOGL.BA\",\"name\":\"Google Inc.\",\"exch\":\"BUE\",\"type\":\"S\",\"exchDisp\":\"Buenos Aires\",\"typeDisp\":\"Equity\"},{\"symbol\":\"1916494.EX\",\"name\":\"GOOGLE-A\",\"exch\":\"EUX\",\"type\":\"S\",\"exchDisp\":\"EUREX Futures and Options Exchange \",\"typeDisp\":\"Equity\"},{\"symbol\":\"GGQ7.DE\",\"name\":\"Google Inc.\",\"exch\":\"GER\",\"type\":\"S\",\"exchDisp\":\"XETRA\",\"typeDisp\":\"Equity\"},{\"symbol\":\"GOOAV\",\"name\":\"Google Inc.\",\"exch\":\"NMS\",\"type\":\"S\",\"exchDisp\":\"NASDAQ\",\"typeDisp\":\"Equity\"},{\"symbol\":\"GGQ7.MU\",\"name\":\"GOOGLE-C\",\"exch\":\"MUN\",\"type\":\"S\",\"exchDisp\":\"Munich\",\"typeDisp\":\"Equity\"}]}})";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}