$re = '/(?<=\(.*)(".*?")(?=.*\))/';
$str = 'body paragraph text (the "first phrase to capture" or the "second phrase to capture").';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);