re = /(?<=\(.*)(".*?")(?=.*\))/
str = 'body paragraph text (the "first phrase to capture" or the "second phrase to capture").'
# Print the match result
str.match(re) do |match|
puts match.to_s
end