package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[0-9]{5}\b|\b[0-9]{3} [0-9]{2}\b`)
var str = `Korpstigen 126 183 34 Kalmar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}