$re = '~\b[0-9]{5}\b|\b[0-9]{3} [0-9]{2}\b~m';
$str = 'Korpstigen 126 183 34 Kalmar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);