#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=\d* \d*$)0[1-9 ][\d ]{9,10}$"
Local $sString = "0123 122222" & @CRLF & _
"00213123 21" & @CRLF & _
"123123 1233" & @CRLF & _
"09 12312333" & @CRLF & _
"0 1111111133" & @CRLF & _
"01234 555 523" & @CRLF & _
"08374873 8" & @CRLF & _
"08654654 654"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")