$re = '/ -[^ ]* ((?:(?! -[^ ]* ).)*)/ms';
$str = ' -one
1 text....
text...
-two
2 text....
text...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);