re = / -[^ ]* ((?:(?! -[^ ]* ).)*)/m
str = ' -one
1 text....
text...
-two
2 text....
text...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end