package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w :,]+(#(?:[a-fA-F0-9]{3}|[a-fA-F0-9]{6}))\b`)
var str = `#BED
{
color: #FfFdF8; background-color:#aef;
font-size: 123px;
background: -webkit-linear-gradient(top, #f9f9f9, #fff);
}
#Cab
{
background-color: #ABC;
border: 2px dashed #fff;
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}