re = /[\w :,]+(#(?:[a-fA-F0-9]{3}|[a-fA-F0-9]{6}))\b/
str = '#BED
{
color: #FfFdF8; background-color:#aef;
font-size: 123px;
background: -webkit-linear-gradient(top, #f9f9f9, #fff);
}
#Cab
{
background-color: #ABC;
border: 2px dashed #fff;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end