import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\/\\/:)[\\r\\n]*(.*?)(?=[\\r\\n]*\\/\\/\\~[\\r\\n]*\\*)";
final String string = "*Listing 1.\n"
+ "//:\n"
+ "some code\n"
+ "//~\n"
+ "*\n"
+ "*Listing 2.\n"
+ "//:\n"
+ "some new code\n"
+ "//~\n"
+ "*";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}