re = /(?<=\/\/:)[\r\n]*(.*?)(?=[\r\n]*\/\/\~[\r\n]*\*)/
str = '*Listing 1.
//:
some code
//~
*
*Listing 2.
//:
some new code
//~
*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end