using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}:[0-9]{1,4}\b";
string substitution = @"";
string input = @"121.121.121.121:8081 2.103384 Китай high 05-07-2014 09:25:17
222.222.222.222:8081";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}