package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}:[0-9]{1,4}\b`)
var str = `121.121.121.121:8081 2.103384 Китай high 05-07-2014 09:25:17
222.222.222.222:8081`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}