import re
regex = re.compile(r"^\s*(\d+)\s*(.*\S) .*\R((?s:.*?))\R\h*F\d{6}", flags=re.UNICODE | re.MULTILINE)
test_str = (" 1 DOPPEL TYP I MEERBLICK HALBPENSION\n"
" FRÜHBUCHER 20%\n"
" INKL. REISELEITUNG UND TRANSFER AB/BIS\n"
" FLUGHAFEN\n"
" KEIN INFO-TREFFEN IM HOTEL! REISELEITUNG IST TELEFONISCH ZU ERREICHEN UND AUF ANFRAGE\n"
" F367655 HERR WILKAT, CHRISTINE O 05.01.15\n"
" F367655 HERR LEBEDIES, HANS-JOACHIM O 05.01.15")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")